Toyota Prius Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
So I just got back from a 10 day vacation, 2009 Prius sat unused in driveway all that time.

Come home, hop in the car, and the radio turns off/on intermittently, and all of a sudden the MFD kind of is on it's own program. Worked perfectly fine before I left.

Resets to the logo about every minute or so. Sometimes lines appear, sometimes it slowly fades to white and then reboots, sometimes it just goes black and reboots...

I mean, the MFD failing I can understand, but why so suddenly? Could it be because it's sat in the CA heat for so long?

Is there anything else I should check or should I just bite the ebay bullet and try to find a replacement MFD? I sincerely doubts it's the 12v battery since it's pretty new and the MFD going bonkers has never been a problem the OTHER couple times the 12v went bad.
 

·
Super Moderator
'17 C 4
Joined
·
687 Posts
EVERYTHING in the world works just fine, right up to the instant that it fails.
No magic involved in that.

If you blindly ASSume that the battery is not the problem, it might cost you a LOT of time and money in the end.

Does the car start and run OK ?
That is kind of an important detail.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
EVERYTHING in the world works just fine, right up to the instant that it fails.
No magic involved in that.

If you blindly ASSume that the battery is not the problem, it might cost you a LOT of time and money in the end.

Does the car start and run OK ?
That is kind of an important detail.
Yup, aside from the MFD, it's tip-top.

Starts and runs as normal.
 
1 - 3 of 3 Posts
Top