Am I the only one with this problem? - Toyota Prius Forum : Toyota Prius Forums
 
LinkBack Thread Tools
post #1 of 3 Old 11-03-2015, 05:12 PM Thread Starter
Junior Member
 
Join Date: Oct 2015
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Default Am I the only one with this problem?

I have a 2004 Prius. My stereo's illuminated display doesn't work. Radio works fine. Does this mean I need the whole unit replaced? Is the dealership the only place to get this replaced?
Pureco99 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 11-03-2015, 09:13 PM
Super Moderator
 
Join Date: May 2014
Location: N. Central Florida
Posts: 357
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 42 Post(s)
Default

Probably not "repairable" but "used" ones should not be too hard to find (Junk yard).

Or a car audio place would LOVE to sell you a better one to replace it.

'17 Prius C-4
Easy Rider is offline  
post #3 of 3 Old 11-04-2015, 11:11 AM Thread Starter
Junior Member
 
Join Date: Oct 2015
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Default

Thanks. I will look into these options.
Pureco99 is offline  
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome